Vista: FileMaker cannot share files because..

Vraag en antwoord over FileMaker Pro 9

Berichtdoor AvD » 02 jan 2008 16:37

Ik probeer de naam van de werkgroep te controleren.
In het Configuratiescherm > Systeem staat voor Werkgroep: "Niet beschikbaar".
Daarnaast staat: Instellingen wijzigen.
Als ik daar op klik, krijg ik deze boodschap:
"De status van de pipe is ongeldig."
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor JeanWM » 02 jan 2008 16:45

Margritte zei dat toch al ...?
Avatar gebruiker
JeanWM
 
Berichten: 1844
Geregistreerd op: 25 jun 2002 07:38
Woonplaats: Ergens, op een kruising tussen tijd en ruimte

Berichtdoor AvD » 02 jan 2008 22:33

Ja, inderdaad, dat zei Magritte ook al.
En ik zit hier zo Off Topic als maar zijn kan, want dit heeft totaal niks te maken met FileMaker, maar alles met die catastrofe die onder de naam Vista op de markt gebracht is.
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor JeanWM » 03 jan 2008 00:56

't was maar om te zeggen dat ik even zonder verder idee zat. 8)

Tweede shot in the dark.

Je zegt dat je problemen hebt met het opstarten van een bestand....

Plaats dat bestand eens in de Public folder van Vista.

Dus Filemaker opstarten zonder Network sharing, vanuit FileMaker naar het bestand in de Public folder gaan.

Probeer het met twee verschillende instellingen:
1. Don't allow people using this computer...
2. Allow people using this computer.....

...to share files etc....
Avatar gebruiker
JeanWM
 
Berichten: 1844
Geregistreerd op: 25 jun 2002 07:38
Woonplaats: Ergens, op een kruising tussen tijd en ruimte

Berichtdoor AvD » 03 jan 2008 01:08

OK, Jean, morgen vroeg begin ik eraan.
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor JeanWM » 03 jan 2008 01:54

André, is het zo dat je met een niet engelse versie van Vista zit ?? 8O
Avatar gebruiker
JeanWM
 
Berichten: 1844
Geregistreerd op: 25 jun 2002 07:38
Woonplaats: Ergens, op een kruising tussen tijd en ruimte

Berichtdoor AvD » 03 jan 2008 01:58

Ja, Nederlands, want de "status van de pipe is ongeldig". Dat klinkt nogal zoals het FileMaker Nederlands.
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor JeanWM » 03 jan 2008 02:07

Vandaar dat ik onmiddellijk aan Magritte dacht....met dat pipeke in het midden...

Maar voor de niet zo lol en om zeker te zijn...

Doe eens een telnet op alle mogelijk door FileMaker gebruikte poorten:

591
2399
5003
5013

Enkel voor de zekerheid...

En staan de attributes voor het bestand op 'Archive' ?
Avatar gebruiker
JeanWM
 
Berichten: 1844
Geregistreerd op: 25 jun 2002 07:38
Woonplaats: Ergens, op een kruising tussen tijd en ruimte

Berichtdoor burggraaf » 03 jan 2008 10:27

Heb hier overigens iets vergelijkbaars of wellicht zelfs gelijkwaardigs met Vista. De melding ken ik dus...

Heb me er echter nog niet echt in verdiept. Krijg de melding als ik een bestand shared zet en op 'all users'. Als ik 'm dan lokaal open krijg ik de melding...

Van wat ik me herinner is dit onstaan na de 1e update van FM9....
burggraaf
 
Berichten: 761
Geregistreerd op: 08 jun 2004 17:45

Berichtdoor Wim Bongertman » 03 jan 2008 10:36

Ik volg deze discussie al enkele dagen met grote interesse.

Ik heb vista home premium. Filemaker 9 advanced is geinstalleerd in de map program files en er zijn geen gebruikers aangemaakt. Alles loopt als een zonnetje. Ik heb dat al eerder opgemerkt.

Ik heb een programma gecompileerd binnen filemaker en als runtime in een map op de c drive geplaatst. Ik krijg hem werkelijk niet aan de loop. Niet eens opgestart zelfs. De boel blijft hangen en is ook niet af te sluiten. Maak ik echter een map in in de map program files en plaats de runtime daar in, dan loopt alles prima. In XP werkt het op de cdrive in een willekeurig aangemaakte map prima. In mijn geval vermoed ik dat het iets te maken heeft met rechten die gebruikers hebben op de diverse niveau's in Vista. Maar ik kom er nog niet uit waar dan precies het probleem zit.

Ik heb dermate weinig verstand van dit soort problematiek dat ik alles altijd maar standaard installeer en op die plaatsen die worden gesuggereerd. Jullie zijn dermate ervaren gebruikers dat installaties nog wel eens "custom made" worden aangepast, onder XP wilde dat ook gemakkelijk maar daar schijnt Vista een enorme hekel aan te hebben.

Kan in dit verhaal een deel van de oplossing zitten?
Wim Bongertman
 
Berichten: 344
Geregistreerd op: 23 nov 2002 19:49
Woonplaats: groningen

Berichtdoor AvD » 03 jan 2008 11:00

Ik denk, Wim, dat je de kern van de zaak te pakken hebt, en dat we helemaal in de door jou gesuggereerde richting moeten gaan zoeken.
Je slaat de spijker op de kop wanneer je zegt dat we nogal snel overgaan tot custom made oplossingen, die dan botsen met de nieuwe security features van Vista.
Eerst moeten we ons dus zeer grondig verdiepen in die Vista-zienswijze (en dan nog in de veronderstelling dat de toepassing ervan bugvrij werkt...).
Dank voor je suggestie!!
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor burggraaf » 03 jan 2008 11:26

Wim, waar jij tegenaan loopt is de security binnen Vista en je hebt, met de map program files, ook waarschijnlijk te maken met virtualisation... (iets om rekening mee te houden met runtimes!!!).

In mijn optiek is dit anders wat niet wil zeggen dat het geschetste probleem niet met Vista te maken heeft. Aan de ander kant... probleem is pas met een update van FM9 op gaan treden hier...
burggraaf
 
Berichten: 761
Geregistreerd op: 08 jun 2004 17:45

Berichtdoor JeanWM » 03 jan 2008 14:41

Het probleem waar oa. André tegenaanloopt hebben we in de jonge versies van XP ook meegemaakt.

Zelfs in het begin van Win NT.

Het Margritte probleem is error 230, een bekende achter de schermen.

Dat dit nu ook weer opduikt bij het begin van Vista is een bevestiging dat de meeste code binnen Vista 're-used' code is.
Blijkbaar hebben de programmeurs de bijkomende patch lijst niet goed gelezen.

Het heeft te maken met toegangsprivileges. Kwestie is de juiste combinatie te vinden om het geheel aan de praat te krijgen of te wachten tot er een update komt.

Zou het toeval zijn dat er problemen met de 'toegang' zijn, terwijl de grote baas 'Gates' noemt ? 8O
Hij doet zijn naam dan wel eer aan..... :roll:
Avatar gebruiker
JeanWM
 
Berichten: 1844
Geregistreerd op: 25 jun 2002 07:38
Woonplaats: Ergens, op een kruising tussen tijd en ruimte

Voorlopig einde, maar zonder oplossing

Berichtdoor AvD » 03 jan 2008 16:16

Wat Jean schrijft, klopt helemaal met de ervaringen van vandaag.
Ik vond deze morgen dat het lang genoeg geduurd had en heb er dan maar een netwerkspecialist bijgehaald, een grote, een die ik al lang ken en bewonder omwille van zijn kennis en bekwaamheid.
Het is nu vier uur in de namiddag. Het netwerk draait weer, er kan weer geprint worden en file sharing is ook weer mogelijk. Het enige wat nog niet kan, is het initiële probleem: "FileMaker cannot share...".
Ik heb vandaag goed opgelet en ben samen met die specialist op duizelingwekkende diepten in Vista geweest, heb daar de meest complexe security-systemen en instellingen gezien. Dat alles gecombineerd met de aanbreng (???) van Norton en de Windows FireWall. Heel wat parameters zijn gewijzigd, sommige zaken uitgeschakeld. Echt duizelingwekkend...
Jean heeft gelijk, en wat hij zei is hier ook letterlijk gezegd door die man: dezelfde problemen als in de beginperiode van XP.
Morgen gaat deze computer weg en wordt daar XP opgezet. De Vista licentie stuur ik terug naar Microsoft. Dan kunnen ze die in hun kerstboom hangen. Hun geld mogen ze zelfs houden.
Ik zal wel zien als er weer patches gaan uitkomen...
Dank iedereen voor de hulp en het meedenken. We weten nu met zekerheid dat het TCP IP dialect van FileMaker niet behoorlijk geïnterpreteerd kan worden door Vista en dat het nu eens wel, dan weer niet door de mazen van het security-net glipt.
Avatar gebruiker
AvD
FileMaker Guru
 
Berichten: 3129
Geregistreerd op: 15 sep 2002 03:55

Berichtdoor peterS » 03 jan 2008 22:19

Andre, ik had een tijd geleden iets soortgelijks, weliswaar op Mac maar wie weet heb je er wat aan. Dit was de FAQ die ik naar aanleiding van dat probleem had aangemaakt:

When starting a IWP session on the same machine as FMS-Advanced, the work files may no longer open without the message that another FMP is already open for sharing.

Failing to stop the IWP session using:
• the console of FMSA
• disabling Personal Websharing in System Preference/Sharing
• and try a restart


the following Terminal command may kill the application :
sudo SystemStarter stop "FileMaker Web Publishing"


De terminal command zal je moeten vervangen door een Windows services command, mijn punt is dat een IWP setting je misschien parten speelt?
Avatar gebruiker
peterS
 
Berichten: 30
Geregistreerd op: 01 feb 2007 00:30

VorigeVolgende

Keer terug naar FileMaker 9



Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast