Jump to content
  • 0

Punt - Komma met letfunctie ??


Maloud

Question

Ik heb een zeer uitgebreide database op autogebied en nogal wat velden waar getallen (financieel) ingevuld moeten worden.

 

Waarschijnlijk snap je al waar het naartoe gaat. Is het ook mogelijk met deze LET functie de PUNT automatisch te vervangen door de KOMMA en zou je aub (svp) een voorbeeldje kunnen maken.

 

Ik werk uiteraard op een (Windows) bureau computer en gebruik het nummerieke gedeelte en de punt die daarop zit. (Amerikaans toetsenbord indeling)

 

Bovendien laat ik het nummerieke veld ook nog door FM 9 Advanced de duizendtallen tonen met een PUNT

 

Ik hoop dat ik het zo duidelijk heb uitgelegd en dat je er iets mee kunt.

Link to comment

21 answers to this question

Recommended Posts

  • 0

Zeker knap! Ik gebruik onderstaande custom function al een tijd om de comma door een punt te vervangen zodat ik decimale waarden in diagrammen kan gebruiken. De jouwe is echter veel beter :D

 

Case ( GetAsBoolean ( PatternCount ( Field ; "," )) = "0" ; Field ;

Field <1 ; "0" & "." & Right ( Field ; Length ( Field ) - Position ( Field ; "," ; Length ( Field ) ; -1 ) ) ;

Left ( Field ; Position ( Field ; "," ; 1 ; 1 ) -1 ) & "." & Right ( Field ; Length ( Field ) - Position ( Field ; "," ; Length ( Field ) ; -1 ) ) )

Edited by Guest
Link to comment
  • 0
Ik vind het voorbeeldje om het punt naar komma te wijzigen prachtig maar merk dat het niet werkt als ik deze formule in mijn eigen databank gebruik.

Dien ik op iets te letten.

 

...het niet werkt is nogal vaag.

 

Wat is het resultaat ?

 

Controleer of "Do not replace existing value of field" unchecked is, is het enige dat op dit ogenblik opkomt als zijnde mogelijke oorzaak.

Link to comment
  • 0

Do not replace existing value of field" staat unchecked

 

Hij haalt de punten eruit met bovenstaand voorbeeld maar plaatst de komma's niet.

 

Let ( puntkomma = Filter ( getal;"0123456789,." ); Substitute ( puntkomma; "."; "," ) )

Link to comment
  • 0

Is je getal veld geformateerd:

Separators/decimals = ","

Use thousand separator = "."

 

FYI, ik gebruik de formule:

 

Let ( 
Self = Filter ( Self ;"1234567890,." ) ;

Substitute ( Self ; "." ; "," )

)

 

Op die manier kan ik geen verkeerde parameter gebruiken en het kan gebruikt worden zonder wijziging op ieder ander numeriek veld.

Link to comment
  • 0
Is je getal veld geformateerd:

Separators/decimals = ","

Use thousand separator = "."

 

FYI, ik gebruik de formule:

 

Let ( 
Self = Filter ( Self ;"1234567890,." ) ;

Substitute ( Self ; "." ; "," )

)

 

Op die manier kan ik geen verkeerde parameter gebruiken en het kan gebruikt worden zonder wijziging op ieder ander numeriek veld.

 

Indien ik het getalveld wijzig in een tekstveld is alles perfect.

maar dat is niet echt de bedoeling.

Alles staat aangevinkt zoals je schrijft.

Link to comment
  • 0
Is je getal veld geformateerd:

Separators/decimals = ","

Use thousand separator = "."

 

FYI, ik gebruik de formule:

 

Let ( 
Self = Filter ( Self ;"1234567890,." ) ;

Substitute ( Self ; "." ; "," )

)

 

Op die manier kan ik geen verkeerde parameter gebruiken en het kan gebruikt worden zonder wijziging op ieder ander numeriek veld.

 

Al deze methodes werken, de laatste is inderdaad erg makkelijk.

 

Alleen bij invoer van een negatief getal werkt het niet :) (Dat wordt weer een normaal getal.

Link to comment
  • 0

Op het eerste zicht niks verkeerd.

 

Bij het aanmaken van een nieuw veld verkrijg ik hetzelfde (verkeerde) resultaat.

 

Echter, bij het aanmaken van een nieuwe file loopt alles goed.

 

Mijn vermoeden is dat je bestand ergens een corruptie zou kunnen hebben.

 

Probeer eens met een volledig nieuw bestand aan te maken.

 

(Alles werd hier wel in FileMaker 11 aangemaakt)

Link to comment
  • 0

Ik heb al verschillende files aangemaakt.

Kan dit iets te maken hebben met een instelling binnen Filemaker.

Ook is het niet mogelijk om die databank waarin ik het nodig heb volledig te vernieuwen.

Hier werd ook alles aangemaakt in Filemaker 11 advanced.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...