Jump to content
  • 0

veldgrootte variabel maken


halph

Question

Hallo,

 

ik heb een vraag over variabele veldgrootte die ik afhankelijk zou willen hebben van de inhoud van het record.

Bijgaande vind je een portaal met daarin de mogelijkheid een aantal beschrijvingen te maken die uiteindelijk in een factuur terecht moeten komen.

Wat echter gebeurt bij het weergeven van de portaal op een factuur, is dat de beschrijving wordt afgekapt op de maat van de portaalregel.

Ik begrijp dat ik op de factuur eigenlijk niet zou moeten werken met portalen maar de vraag is hoe dan wel zodanig dat de grootte van de beschrijvingen variabel is.

5a758dc95e070_Afbeelding3.png.9ad8b5291084535df7f06838ef19692e.png

5a758dc9612b5_Afbeelding2.thumb.png.2714d0ec1153c16a19dadd90bb620d74.png

Link to comment

4 answers to this question

Recommended Posts

  • 0

Het is in "Browse mode" niet mogelijk om de veldgrootte variabel te maken.

 

In "Preview mode", kun je wel de velden voldoende groot maken, en ze bij het printen (of in Preview mode) doen "sliden" (lees krimpen) tot ze net zo groot zijn dat al de tekst erin past (dus een beetje het omgekeerde dan wat je eigenlijk zoekt). Dit gaat ook voor portals.

 

Uit je voorbeeld is echter niet duidelijk dat je dit wilt om af te drukken, of ook in gewone browse mode (in het laatste geval is het volgens mijn kennis niet mogelijk).

Link to comment
  • 0

Het gaat mij inderdaad om het printen van een factuur.

Kun je me uitleggen hoe dat "sliden" werkt?

 

Inmiddels heb ik mij afdruk lay-out zodanig gewijzigd dat hij werkt met lijstweergave. En dus niet op basis van een portaal werkt. Maar het probleem blijft hetzelfde. Dus ik hou me aanbevolen voor een oplossing.

Link to comment
  • 0

hier vind je alvast meer uitleg:

 

http://www.filemaker.com/help/06-Create%20and%20manage46.html

 

 

Ik werk voor print layouts idd het liefst met lists ipv portals. In kort komt het hierop neer: je maakt je velden voldoende groot, zodat de maximale hoeveelheid tekst er zeker volledig inpast. Nu komt het er op neer om die velden te doen krimpen indien ze niet volledig "gevuld" zijn met data. Dit doe je dus door de sliding. Deze functie vind je onder: Format -> Set Sliding/Printing. Ik denk dat de settings die jij wilt, hieronder goed zijn afgebeeld.

 

De rede dat je de optie "Also reduce the size of enclosing part" moet aanvinken is om de body mee te doen krimpen. Indien je dit niet wilt, moet je dit laten afstaan.

 

Veel succes !

5a758dc96310b_Picture2.png.7bcc4d4abfd34b86a2074121e58d5c01.png

Link to comment
  • 0
Ik begrijp dat ik op de factuur eigenlijk niet zou moeten werken met portalen

Het woordje "eigenlijk" moet hier "eigenlijk" al weg :wink: .

Da's een.

FileMaker heeft ooit geschreven dat portals nooit bedoeld waren om afgedrukt te worden. De print engine van FileMaker is daar dan ook niet specifiek op gericht.

 

Je print dus in list mode, niet in de parent table, maar in de child table.

Daarbij zorg je voor voldoende grote body parts, die je dan weer reduceert via sliding, zoals hierboven al mooi is toegelicht.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...